[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4756: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3891)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4758: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3891)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4759: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3891)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4760: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3891)
Open Music Labs Forums • View topic - using slower sample rate

using slower sample rate

using slower sample rate

Postby rputra » Thu Apr 10, 2014 10:54 pm

rputra
 
Posts: 3
Joined: Thu Apr 10, 2014 10:42 pm

Re: using slower sample rate

Postby guest » Fri Apr 11, 2014 12:32 am

i would suggest running the sine_generator test code, and seeing if you can generate a 1khz tone by turning the knob. what im suspecting is happening, is that your increment calculation is turncating, and you are jumping ahead by 512 samples each time. but, if you start at position 0, you jump to 512, and then to 0, etc. the values at 0 and 512 are identical, and therefore no output is produced.
guest
Site Admin
 
Posts: 449
Joined: Thu May 20, 2010 11:58 pm

Re: using slower sample rate

Postby rputra » Mon May 12, 2014 5:43 pm

Thanks, that is exactly what happened. I tried to generate a little bit higher frequency (i.e. at 1.25 kHz), and it worked.
rputra
 
Posts: 3
Joined: Thu Apr 10, 2014 10:42 pm


Return to Audio Codec Shield

Who is online

Users browsing this forum: No registered users and 1 guest


cron