Squealing alpha

Squealing alpha

Postby davehayden » Mon Oct 28, 2013 3:06 pm

I ordered a Mixtape Alpha board from OSHPark (looks great in purple and gold!) and put it together this morning without much trouble. The mixtape.hex flashed and verified via avrdude without any problem. When I power it up, though, it screams at around 3800 Hz, just ear-splitting. I tried mixtape_avr_new.hex instead and it's even worse. The buttons react as expected, and they change the noise it's making (usually louder and more painful), but it's always got that 3800 Hz tone going.

Any thoughts?
Attachments
pain.jpg
AGGGGGH! MAKE IT STOP!
pain.jpg (96.79 KiB) Viewed 51856 times
davehayden
 
Posts: 3
Joined: Mon Oct 28, 2013 2:09 pm

Re: Squealing alpha

Postby guest » Mon Oct 28, 2013 6:58 pm

did you set the fuses? im betting the CK/8 fuse hasnt been cleared. there are a few other fuses that need setting as well, you should take a look at the top of the .asm file for the correct fuse settings. awesome job, by the way. and definitely use the new_experimental.hex.
guest
Site Admin
 
Posts: 449
Joined: Thu May 20, 2010 11:58 pm

Re: Squealing alpha

Postby davehayden » Tue Oct 29, 2013 11:24 am

That was it! Thanks so much! We'll be putting the other 2 boards together tomorrow at our local hackerspace open night, really glad to have this sorted before then. My hope is we can get some visual artists interested in doing custom art for a second batch.

Here's how they came out:
mta1.jpg
mta1.jpg (38.15 KiB) Viewed 51852 times

mta2.jpg
mta2.jpg (34.47 KiB) Viewed 51852 times


I don't see new_experimental.hex in the files section on the wiki. Is that the same as mixtape_avr_new?

Thanks again for the help, and bigger thanks for making this open source! I can't wait to start poking at the code and figure out how this thing works. :)
davehayden
 
Posts: 3
Joined: Mon Oct 28, 2013 2:09 pm

Re: Squealing alpha

Postby guest » Tue Oct 29, 2013 11:37 am

yeah, i changed the name on the link so it would be less confusing. its the V2.0 files.

the mixtape looks great. be sure to clean the board really well, as the flux can make it work poorly. also, if you end up doing another run, you may want to tent your vias, as it gives the surface a cleaner look. did you make those straight from the gerber files? or did you rerun the gerbers from the eagle files?
guest
Site Admin
 
Posts: 449
Joined: Thu May 20, 2010 11:58 pm

Re: Squealing alpha

Postby davehayden » Tue Oct 29, 2013 3:00 pm

I made a couple of tweaks in Eagle—used a different battery clip I had laying around, and changed the ISP header for pogo pins.

Good point about the vias, thanks!
davehayden
 
Posts: 3
Joined: Mon Oct 28, 2013 2:09 pm


Return to Mixtape Alpha

Who is online

Users browsing this forum: No registered users and 1 guest


cron