Audio Codec Shield on FPGA BCLK always low

Audio Codec Shield on FPGA BCLK always low

Postby MarijnvanTricht » Thu Jan 15, 2015 8:46 am

I have connected the Codec shield to a FPGA and when i configure the BCLK (generated from the CLKOUT) on an unused pin it works fine. But when I connect it to the Codec shield it goes low.

anyone know what could be the problem?

Aditional information:
- the chip is running slave (so i have to provide the clocks)
MarijnvanTricht
 
Posts: 2
Joined: Thu Jan 15, 2015 8:38 am

Re: Audio Codec Shield on FPGA BCLK always low

Postby guest » Thu Jan 15, 2015 12:33 pm

are you sending BCLK to pin13 (D13) on the codecshield? this is the 3rd pin down on the upper right hand side of headers (with text facing upright). the pin above it is ground, so make sure its not shorted to that pin for some reason. measure the resistance to ground with a multimeter.
guest
Site Admin
 
Posts: 449
Joined: Thu May 20, 2010 11:58 pm

Re: Audio Codec Shield on FPGA BCLK always low

Postby MarijnvanTricht » Fri Jan 16, 2015 4:10 am

Thanks that was it. I can't see it but there is definitely a short between the BCLK and the ground.
MarijnvanTricht
 
Posts: 2
Joined: Thu Jan 15, 2015 8:38 am

Re: Audio Codec Shield on FPGA BCLK always low

Postby guest » Fri Jan 16, 2015 12:34 pm

were you able to fix it? if you soldered wires to the shield, somtimes a small bit of solder can jumper to the ground plane.
guest
Site Admin
 
Posts: 449
Joined: Thu May 20, 2010 11:58 pm


Return to Audio Codec Shield

Who is online

Users browsing this forum: No registered users and 1 guest


cron