Error Compiling

Error Compiling

Postby vaxon » Mon Jun 11, 2012 10:18 am

Hello,
For some reason the examples aren't compiling for me.

"
In file included from sine_generator.cpp:19:
E:\Program Files (x86)\arduino-1.0\libraries\AudioCodec/AudioCodec.h: In function 'void AudioCodec_init()':
E:\Program Files (x86)\arduino-1.0\libraries\AudioCodec/AudioCodec.h:159: error: 'wire' was not declared in this scope
"
Line 159 of AudioCodec.h is the first time is does wire.write. I tried adding #include <Wire.h> in AudioCodec.h but it didn't make a difference.

Using Arduino 1.0.
Wire.h and SPI.h are in the correct places. I can include them in other sketches.
I put the files in the Arduino libraries directory as well as "My Documents\Arduino\libraries\" as instructed in AudioCodec.h

Any Ideas?
vaxon
 
Posts: 4
Joined: Mon Jun 11, 2012 10:01 am

Re: Error Compiling

Postby guest » Mon Jun 11, 2012 5:59 pm

we have 2 different arduino libraries
because arduino didnt make 1.0 backwards compatible

it looks like youre using arduino1.0
are you using the appropriate codecshield library?
guest
Site Admin
 
Posts: 449
Joined: Thu May 20, 2010 11:58 pm

Re: Error Compiling

Postby vaxon » Tue Jun 12, 2012 10:06 am

Tried all three zips for here and "AudioCodecNew.zip" worked. "AudioCodecNew1.zip" does not. Is it compatible with ardunio1?

Thanks!
vaxon
 
Posts: 4
Joined: Mon Jun 11, 2012 10:01 am

Re: Error Compiling

Postby guest » Tue Jun 12, 2012 12:18 pm

i must have screwed something up when uploading new files
i will fix that

im glad you got it working
and thanks for finding that bug
guest
Site Admin
 
Posts: 449
Joined: Thu May 20, 2010 11:58 pm

Re: Error Compiling

Postby guest » Thu Jun 14, 2012 12:20 am

ok i think i fixed it
if you want to try using New1 again

i also found a few bugs in New while i was in there as well
guest
Site Admin
 
Posts: 449
Joined: Thu May 20, 2010 11:58 pm

Re: Error Compiling

Postby instantplaces » Mon Aug 13, 2012 3:34 pm

I'm having the same problem-- examples do not compile.

"sine_generator.pde:-1: error: 'AudioCodec_init' was not declared in this scope"

sine_generator.cpp:19:24: error: AudioCodec.h: No such file or directory
sine_generator.cpp:43:27: error: sinetable.inc: No such file or directory

Tried all 3 libraries in Documents/Arduino/libraries. Tried Arduino 1.0 and 1.0.1.
instantplaces
 
Posts: 6
Joined: Mon Aug 13, 2012 3:27 pm

Re: Error Compiling

Postby guest » Mon Aug 13, 2012 5:44 pm

what is your setup?
arduino uno and arduino1.0?
ive only got a duemilanove handy
but will check on that
guest
Site Admin
 
Posts: 449
Joined: Thu May 20, 2010 11:58 pm

Re: Error Compiling

Postby instantplaces » Mon Aug 13, 2012 5:54 pm

yes-- setup is arduino uno, arduino 1.0
osx 10.6.4
instantplaces
 
Posts: 6
Joined: Mon Aug 13, 2012 3:27 pm

Re: Error Compiling

Postby guest » Mon Aug 13, 2012 6:00 pm

just verified that the libraries up on the wiki
work with arduino1.0 on a duemilanove

i remember the libraries folder being difficult to find on osx
is the sine generator sketch showing up under file->libraries->examples?
guest
Site Admin
 
Posts: 449
Joined: Thu May 20, 2010 11:58 pm

Re: Error Compiling

Postby guest » Mon Aug 13, 2012 6:08 pm

just checked on an uno
and that worked as well

i noticed that the libraries are in a subfolder inside the zip file
be sure to take the library out of the subfolder
when moving it into the library directory

i will fix that on the wiki page
as it might cause some confusion
guest
Site Admin
 
Posts: 449
Joined: Thu May 20, 2010 11:58 pm

Next

Return to Audio Codec Shield

Who is online

Users browsing this forum: No registered users and 1 guest


cron